Tesla users - HEMS update breaking change

For Tesla users - the latest update to Home Assistant seems to have changed the tesla integration - both for the Powerwall and car, meaning the integration will have stopped working recently.
The issue is around authentication with the Tesla system, and I believe you can fix this issue by removing and installing the app again.
@Oscar_Scott I know this is affecting you and there may be others.
For more details there is information on Github here - Use oauthv3 for Tesla by alandtse · Pull Request #45766 · home-assistant/core · GitHub


Hi Peter,
Thanks for the heads up, but my Tesla integration had already broken when my previous oauth token expired… thankfully the new update has fixed it now so all back up and running. If only the Smartthings integration was as quick to update! Just been trying to work out a way to pass the battery information from HA to ST now.

1 Like

Good to hear you’re ahead of the curve on this, but not that you’re having to fix broken integrations during updates/ expirations. Let us know how it goes with the next step, and if you manage to transfer that info okay.

Glad to hear Oscar - if anyone wants to buy me a Tesla so I can test this stuff properly just get in touch :grin:

1 Like

Hi Polly,
To be clear, the issue was caused by Tesla updating their authentication system, then not really telling anyone, so the rest of the world needing to work out what they had done so all the integrations could work again. Thankfully the Home assistant community is fairly quick on this one, nothing that CCOOP could have done about it.

The next issue I am having is again as a result of Tesla changing their systems, and not really related to the HEMS…

Peter, I am going to try to set up some rules on the HEMS based on powerwall data (current battery level, solar rate, house usage etc) to toggle a few switches, which Smartthings can then pick up. I might need some help on the automations though

1 Like

Thanks Oscar, good to know it’s not a HEMS specific issue, but frustrating none the less. Indicative of interoperability issues which Carbon Co-op is modelling systems to avoid.

Yes, running local devices via MQTT and Tasmota is great and nice and stable, so perfect for the powershaper systems, but I don’t fancy trying to hack my Tesla powerwall to run locally haha.

The next step in energy control would be a open source home battery system like the powerwall, that could use MQTT as the EVSE does. the next step for Carbon COOP perhaps?

1 Like

A similar comment came up in the PowerShaper Q & A today actually - regarding an open source home battery system, so very serendipitous timing. All will be revealed soon from the project lead

Oh, well I’ll be very interested in that, will it be mentioned in the meeting tonight?

@Oscar_Scott it looks like your powerwall integration still isn’t configured correctly - we are seeing errors on our backend system. Is it working ok on your end? Does it need to be reinstalled maybe?

I reinstalled a couple of days ago and it was showing as working - I will have to wait until I get home to check - The Tesla (car) integration is now working fine however

Looks like the integration is working correctly, as I said only fixed it a few days ago though, so maybe those are the errors you are seeing?

Hi Oscar, sorry to reply belatedly. It’s going to be covered by the project lead in a series of presentations later in the year. (March-April)

Hi @ben and @peter ,
I am trying to get more control over my powerwall, so I can charge it based on the predicted amount of solar the next day (so to not draw too much from the grid). my previous setup was a Smartthings integration with powerwall, which could control it, but this has since broken due to the same reasons the HA integration broke.

Unfortunately the built in powerwall integration to Home Assistant only offers sensors and not control.
There is however a component written by the community:

I was wondering if there was something you can do on your end to add this in? This would really help in balancing my home energy usage

Hi Oscar. Is there any more documentation / details on this? Is there much needed to add to the configuration.yaml file?

Hi Peter,
The original post is here:

the creator is the user estebanp,
and it requires
in homeassistant/custom_components, creating a folder “tesla_gateway”. Inside that folder, create a file “init .py”

along with a few other steps.

only this needs adding to the configuration yaml:
username: <username of your tesla account, can be through a secret>
password: <password of your tesla account, can be through a secret>

but stuff needs adding to a “services.yaml” in the previously mentioned folder

Ok, I’ll have a look at this now and see if I can modify it to work with user interface configuration.

Would you be willing to share your username / password with me for testing?

sure, i’ll send you a direct message, I wonder, could it be able to pick up the username and password for the existing tesla integration (car) :thinking:

Hi Oscar. How did you get the Tesla car integration working? When I try to install the Integration it asks for my login, which it then rejects. I’m missing something, but the documentation and HEMS error infomration is risible, so I don’t know where to go next.